760-929-4808 option 2

Recent Microsoft update changes to Windows libraries have caused certain SecureCheck 9 installations to be unable to run using earlier versions of .NET libraries. This may affect SecureCheck on Windows Version 7 and newer.

Some symptoms you may see are:

  • No SecureCheck Tray Icon
  • Pop up error message saying “Class Not Registered”
  • Log errors messages saying “APSettings Error: Class Not Registered”

In order to get around this, re-register SecureCheck to .NET version 4 libraries.

  1. Stop SecureCheck
  2. If you do not have .NET version 4 installed, it should be downloaded from Microsoft and installed
  3. Once installed, execute the following two commands as administrator:

%systemroot%\Windows\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe /tlb APSettingsCOM.dll

%systemroot%\Windows\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe /tlb CryptoSupport.dll

4. Restart SecureCheck and verify printing works.

If the issue persists, please submit a support request ticket.